Today's Question:  What does your work cubicle look like?        GIVE A SHOUT

Technical Article => Business =>  Google

Google+ doesn't support Firefox 23?

  sonic0002      2013-08-10 21:46:27      9,633    9    0

Mozilla just released a new version of Firefox--Firefox 23, but after upgrading to the new version. We cannot login to Google+ anymore, instead it will show a page which says "Your browser is no longer supported" and it gives some choices to download new web browsers.

It also allows to download Firefox. But the thing is we have updated to the latest version. Also when clicking on the "Download Firefox" link, it is redirected to the download Firefox for Android page, is it weird?

Is this because the Google+ code detects the browser version wrongly? Or is it because the new version of Firefox changes the user agent? The user agent for Firefox 23 is:

Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0

While for Firefox 22, the user agent is :

Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20130405 Firefox/22.0

There is no big difference except the version number. So not sure why Google+ doesn't support Firefox 23 now. Hope Google and Mozilla can give some explanation. But before that, these may be some feasible solutions.

  1. Use "What's Hot" link to enter Google+:-
  2. Use User Agent Overrider Add-on for Firefox(change your browser user agent to Chrome 27 or IE10):- 
    Source - Mozilla Support forum:-
  3. Try clearing your browser cache and cookies.
  4. Use a different browser.

   GOOGLE+ FIREFOX 23   Read(9,633) Comment(9) Version(0)




kichik [Reply]@ 2013-08-10 22:57:00

There actually is a big difference. Notice the date after "Gecko/". Firefox 23 reports Gecko version from 2010 which is probably too old for Google+. That seems like a bug in Firefox to me.

extra88 [Reply]@ 2013-08-10 23:24:39

I didn't have a problem logging in even though the OS X version also has an old date in the Gecko part of the User Agent string:

User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0

My guess is Google tweaked their user agent check to account for the new version.

Sergei [Reply]@ 2013-08-11 02:29:17

What is Google+?

NightCat [Reply]@ 2013-08-11 04:45:26

Are u serious?

Me too [Reply]@ 2013-08-25 12:00:20

Google+ is forbidden in China.

abijithkp [Reply]@ 2013-08-11 13:23:21

I just tried out the new firefox 23 on my Arch Linux system. It works fine while using Google+.

Satyadeep [Reply]@ 2013-08-11 23:37:15

I just tried on Windows 8 , no problems logging into Google+ .

NightCat [Reply]@ 2013-08-14 21:31:20

It seems the issue is resolved now.

Samx [Reply]@ 2013-09-18 03:36:20

Is this a plan to increase the traffic for Google+ ?


long long long is too long

By sonic0002
int main(){    long long long int X;    return 0;} The above code compiled with GCC will produce the error above. This is one of the most interesting error messages produced by GCC.


No other version available yet.